Announcement

Collapse
No announcement yet.

Line 6 DL-4 pedal repare

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Line 6 DL-4 pedal repare

    I am asking if anyone would be able to help me with my pedal. I have replaced the LED's and the foot switches. All went well until by mistake or regret I plugged the US power supply 110V into the Australian 240V socket. Now usually that is not a problem as I have others that are fine but this one burned something inside and the power off. But I plugged another power supply in and now I have no lights on the pedal and I believe it must have damaged the pedal.
    My question is could I repair this myself? Could it be just a capacitor or a diode that has been damaged? This may have put too much power into the pedal. Or is it time to bin it and start again with a new pedal and $200?
    Thanks anyone for helping.
    Allan

  • #2
    I did find some information but but any suggestions would be great.
    Allan

    Comment


    • #3
      Take the pedall apart & look right around where the power jack is.
      Chances are you toasted a diode.

      Comment


      • #4
        Thanks. They look ok but now I have the thing apart again I've broken a wire off one of the new switches and will have to drag out the soldering iron again. I'll try the re-boot also.
        Allan

        Comment


        • #5
          No definitely no spark of life. Dead but I can't see any sigh of damage or burn. Just when it happened the two outer lights came on that was first time on. But then they went out and nothing since.
          Allan

          Comment


          • #6
            I have no power across ID16 and U14 is getting hot I noticed. If that is any help?

            Comment


            • #7
              I do not know what the parts are that you designated.
              What is the part# in U14?
              It sounds like it is bad.

              Comment


              • #8
                Line6 DL-4 power supply schematic.

                D16 is a 3.6 volt zener diode.
                Here is a copy of the power supply schematic.
                Attached Files

                Comment


                • #9
                  2: Max887 ( u14 )

                  Comment


                  • #10
                    Here is a copy of an older post:
                    "from the AC-in, power goes throu a 3,6v Zener ( D16 ) then on through D11. the 3,6v zener are known to fail, but doesnt affect battery operation.
                    after D11, power meets up with the battery in... next comes U14, a little 8-pin ( SMD ) MAX887. this one takes things down to 3,3volts ( mesure pin7/ signalground ). if you have 3,3volt on pin7, go on to U20.
                    U20 is a MAX660 wich is a voltage doubler. check the DC voltage on pin1 ( or 8, they are tied together ). if you have 6,6volt here, next in line is a tiny thing called LM3480 ( U21) this one will even out things for the digital domain to 5 Volt...if you havnt found fault yet, and reset doesnt work..dont bother...

                    ..so the most likely suspects are
                    1: 3,6v Zener ( D16 )
                    2: MAX887 ( U14 )
                    3: MAX660 ( U20 )
                    4: LM3480 ( U21 ) "

                    Comment


                    • #11
                      Might be that one that got hot and that one is a bit beyond me. u14 I think. Thanks for your help. I might have to resell it as parts or box it for later. I learned a lesson there. Allan

                      Comment


                      • #12
                        I'll try the voltages at that level and at least I will have an idea of the problem. My meter broke so I'll have to hit Dick Smith for a new one. As I just got out of hospital for a back fusion operation I'll be taking my time and I have the Distortion pedal I got to play with now. Did the mod on that no worries but I should have tossed the power pac that came with the delay pedal. Thanks.

                        Comment


                        • #13
                          I'm going to try the 4.5volt mod to bypass the voltage step down and up etc. There are some good threads to be found if you search. I am willing to try it, if it doesn't work I will have learned a bit more anyway.

                          Comment

                          Girls Out West Busty lesbians masturbate ?????? ????????? ???????? ????? ?????????? porno gay audio latino
                          Working...
                          X