Announcement

Collapse
No announcement yet.

TC Electronic Ditto Looper intermittent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TC Electronic Ditto Looper intermittent

    Hi there

    I have TC Electronic Ditto Looper that is intermittent. It works normally half of the time, but is dead the other half. It's fairly unused and un-abused, but a few years old. I can get it working out of the chassis but then usually once it's put back together its intermittent generally works after a few power cycles, but then stops working again. I'm not REALLY expecting to be able to fix it, loads of folks on the web report faults with these units and theres not much info that seems to suggest an easy fix, no service manual or schematic to speak of. Many have doubted the footswitch, as the pedal shows no life when first plugged in (by design) and needs you to press the footswitch to show the red 'recording LED' as the first user use feedback.

    But my footswitch button (on the pcb) shows good momentary contact when tested, and when the unit is failing to show any life shorting the pcb solder points that I have determined are connected when the footswitch is pressed has no effect. I think the problem is deeper. There I come up short, it's mainly all small smc and large chips apart from the odd cap that so far test in spec.

    I've cleaned the pcb header strips that connect the two pcb's, as well as the jack sockets. There are a tonne of test points but no documentation I can find online which says what they should be. Even if I found a solution I don't have the ability to desolder large chips if one is known to be at fault. All the solder joints look fine.

    So anyway, I'm not really expecting to be able to fix it, but if someone has worked on such a pedal and has a little insight on a component that often goes wrong then that would be a bonus and divert this pedal from it's journey to the trash!
    Last edited by OwenM; 09-24-2020, 11:27 PM.

  • #2
    WHy expect one part that always causes the trouble on your unit? Yours seems to lose power completely? So that won't be an issue with the knobs or the stomp switch.

    ANy chance the wires are broken inside the cable from the power adaptor? Does wiggling the power plug on the unit make it come and go? Inside, is the solder cracked on the power jack? I don't know this unit, but many won't power up unless a guitar cord is plugged into the input, so a problem with that jack can cause such problems.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      Thanks! Well I just thought it worth checking the button as there’s loads of forums with people complaining about the ‘crappy TC buttons they use’, but yeah it’s not that in mine. It's not a usual stomp pedal, when you plug it in the led remains off/unlit (it isn't a mechanical switch, it'll be off when powered up). The stomp switch just houses a spring that presses a momentary switch on the PCB. You press once and it turns red for record when you press again it turns green and flickers at the loop restart point. It's more of a signal generator for the circuit rather than a mechanical on off switch. So the first thing you do when plugging the thing in to see it working is press the switch so feasibly it may have normal power but the switch doesn't work and hence can't get it to start looping.

      I tried a couple of power supplies, and one was my bench supply which is pretty solid! I also made sure the pcb had the 9v on it while the unit was failing to work and it did.

      Yeah, I cleaned the contacts on the switching jacks, but oddly enough this pedal does power up and work normally without jacks plugged in. (It has an led that changes colour for record mode and flickers when it passes the loop begging etc, so you can see it working!)

      I’ll have another once over any connection I can see. After that I guess I’ll google a few of the IC’s and see if they are getting power when the unit is failing to function..
      Last edited by OwenM; 09-25-2020, 11:14 PM.

      Comment


      • #4
        I sent a video of the fault to TC Electronic service and thought I'd upload the vid here, some one may know the issue if its a common one or failing that someone may get one of these in for repair and find they have the same problem as me! It seems this sort of problem is very common on these devices and everyone blames the switch, but, it's not the switch. It's some other dodgy contact somewhere or maybe some other failing component.

        https://youtu.be/SHvucewI1m8


        Comment


        • #5
          FWIW: I clicked on the link. It's a private video asking for a sign in to view. You may want to change that if you can.
          "Yeah, well, you know, that's just, like, your opinion, man."

          Comment


          • #6
            Here is a crop of both boards.
            You have to find out what the switch is triggering.
            It has to 'tell' some component to turn the unit fully on.
            Attached Files

            Comment


            • #7
              Originally posted by The Dude View Post
              FWIW: I clicked...
              Thanks for pointing it out, changed to unlisted so should be viewable now if you feel so inclined

              Originally posted by Jazz P Bass
              Here is a..
              Thanks, yup I figured as much.. it’s hard to see the pcb traces and plenty of large daunting IC’s. The tech support responded to my request and asked for the video so maybe they’ll come up with something, fingers crossed. A service manual would be lovely. If not I may just put this in the cupboard for now and get on with fixing stuff I know more about Return to it with a bit more experience perhaps!

              Comment


              • #8
                It shouldn't be that difficult to find where the switch wires are routed to.
                If they go to the top board through the interboard header, then I would look at the HFD4/3L relay to see if it has anything to do with it.

                Comment


                • #9
                  I'm having trouble SEEING where it's routed too, as its a multilayer board and theres very little evidence of where the traces are going. However I'm getting somewhere (a bit) with testing for continuity. During fail state (which is currently all the time) The switch has 3v on one side, and ground on the other. The relay goes to ground on a few of it's secondary connections (ie the connections controlled by the relay switch). I can't find the 3v on the relay at any point, its all 0v, even on the relay's switch control terminals while holding the button in, but I haven't managed to test it while it was working to see if the switch is giving the 3v trigger to the relay in normal working state (if that is indeed what it is meant to do). It's a 3v relay so I'm thinking my found 3v probably has SOMETHING to do with it. The relay does click on first operation and when you double tap-hold the button to wipe the recordings, but only when it's working.

                  There are a few little IC's that I have found to be opamps but I can't find any voltage on any of them while in fail state. So there is a no power situation on many parts of the board but I can't be sure if its the relay that should be switching things on, or wether thats a red herring and the really is just doing something else regarding resetting the circuit etc.

                  With 3v on one side of the switch and ground on the other it's possibly meant to remove 3v on the relay when pressed to make it flip states to either engage it, or disengage and turn off the led after wiping on a double-tap-hold. With the relay clicking audibly on 'on' and 'off' I guess thats plausible.

                  I guess I could just buy a new relay for 1 and put it in, I'm making an order for another project anyway. But I'm not currently convinced thats the problem? It still seems a little like theres a bad connection, somewhere, though I've looked all over!

                  Well, I'm really not asking for a detailed rundown from anyone here! Just musing, it's a complex thing compared to what I'm used to. A schematic would be a dream but I think thats still secret info. I haven't heard anything from tech support since submitting the vid but maybe they were expecting someone with a wrongly-polarised psu or something!

                  Comment


                  • #10
                    If the ICs have no voltage reaching them, and the relay has no voltage reaching it and who knows what else has no voltage reaching it, then the switch and relay and LED are not the problem. You have a failure in the power supply.

                    Your outboard power adaptor sends some crude voltage into the power jack, but once inside than the system regulates that voltage down to others it needs. SOmething in the power entry circuit has failed.
                    Education is what you're left with after you have forgotten what you have learned.

                    Comment


                    • #11
                      Gotcha, I think I’m letting myself get sidetracked thinking the relay may be the switch that turns power to the circuit off and on, but there’s no voltage on any pin to be switched so must be audio or something.

                      I’ll divert my attention to the power circuit, see if I can work out what’s there.

                      Comment


                      • #12
                        I see a massive microcontroller.
                        On a lot of stereo receivers with lcd readouts, the micro is what starts everything up.
                        And all it would need is that 3 volt pulse from the switch.

                        Comment

                        Working...
                        X