No announcement yet.

Tunderbird email attachments do'nt open

  • Filter
  • Time
  • Show
Clear All
new posts

  • Tunderbird email attachments do'nt open

    Since I abandoned Windows and switched to Ubuntu 18.04.2 LTS I've has a problem with opening attachments in Thunderbird.

    The exact problem is reported by someone else in this post but is unresolved:

    Can anyone here help? After pretty determined research I'm still stumped.

  • #2
    I use web mail, so I don't use Tbird.
    Was wondering if you can download the attachment to a folder or desktop, and open from there?
    If you can download the attachment, and still can't open it, that would point to the need for the appropriate App, or viewer.
    Also I was telling a friend that uses TBird, and he wanted to know what version of Thunderbird you were using?

    "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


    • #3
      Yes - that's the method I've been using but if possible I'd like to open them automatically. My file associations all work fine everywhere else. I deleted Thunderbird then reinstalled it (twice) and applied the updates but it still doesn't work. I've seen a few times about deleting the user profile but can't find out how to do this in detail. I also believe deleting the profile affects other Mozilla applications. version is 60.8.0 64 bit and shows as up to date.


      • #4
        Instead of deleting user profile, can't you create another for testing? Then you won't have to delete your current profile if not necessary.
        "Everything is better with a tube. I have a customer with an all-tube pacemaker. His heartbeat is steady, reassuring and dependable, not like a modern heartbeat. And if it goes wrong he can fix it himself. You can't do that with SMD." - Mick Bailey


        • #5
          I deleted and added thunderbird just to see if I could delete it, then install it again.
          Here are some screenshots how I did it.
          I've had programs hosed up before, and you usually need to reinstall them.
          You need to completely remove it and start over.
          Start with purge
          # apt purge thunderbird
          Then I used MC (midnight commander to delete the Directory) **Be careful with MC /Midnight Commander
          If you don't have midnight commander
          # apt install mc
          See Screenshots.
          When removed, and all gone, then reinstall.
          # apt install thunderbird
          Attached Files
          Last edited by big_teee; 07-28-2019, 03:40 AM.

          "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


          • #6
            I'll save off my data and give it a go. A few drinks of wine an hour ago won't be any help to my concentration so I'll perhaps do this tomorrow morning.......


            • #7
              I installed T-bird on this computer, put my yahoo.mail acct on it.
              I sent myself a pdf, and I can download it, or click on it , it works fine.

              Last edited by big_teee; 07-28-2019, 03:01 PM.

              "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


              • #8
                I attempted to first back up my profile which according to the Mozilla help is under .thunderbird. However, this folder only contains two sub-folders - crash reports and pending pings (this is with displaying hidden files). Another thing came up today - I got a message notifying security updates;

                "A recommended security and stability update is available, but you do not have the system permissions required to install it. Please contact your system administrator, or try again from an account that has permission to install software on this computer. You can always get the latest version of Thunderbird at:"

                I've previously been able to do updates to Thunderbird and install extra features from terminal, so why when I log in to my machine (as administrator - I don't have any other profile) am I not granted global admin permissions in every application?


                • #9
                  I run all updates from terminal.
                  You can do it a variety of ways.
                  There are 3 commands.
                  apt update
                  apt upgrade
                  apt autoremove
                  I run them all at one time
                  apt update && apt upgrade && apt autoremove
                  You will have to hit some returns in progress, after each step runs.

                  You can copy the .thunderbird to another location for backup.
                  With it backed up and saved in another directory area, you can then blow out directory .thunderbird, and start over.

                  Another option, to check out thunderbird, is to run it from a live USB.
                  You could download and run Mint, different Ubuntu's, etc.
                  Also you can run Multiboot Linux.
                  I have 19.04, 19.10, and Fedora FC30, all on this machine.
                  Multiboot gives more options to test out applications, and troubleshoot problems.
                  Last edited by big_teee; 07-28-2019, 10:27 PM.

                  "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


                  • #10
                    Here's some other Ubuntu's you can download and run live.
                    If you want to try thunderbird on some other live systems.
                    Mint is also a user friendly OS.
                    I also like Fedora, but it not as user friendly as Ubuntu, or Mint.
                    **BTW when you log in as a user, you are not running as admin, or root.
                    Some programs will ask for your admin passwd.
                    Last edited by big_teee; 07-28-2019, 10:29 PM.

                    "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


                    • #11
                      I did a reinstal and got a message to run "sudo dpkg --configure -a" manually. Now there's a line in the helper application for .pdf files, which was previously missing, so a step forward. If I now try to browse to the associated application (Evince) from this screen I can navigate as far as usr/bin but then I'm denied permission. I can browse to this in the file manager just fine. It looks to me that the missing bit is that for some reason Thunderbird doesn't have the permission it needs to associate the application.


                      • #12
                        Yes, you need to run
                        $ sudo dpkg --configure -a
                        no quotes.
                        dpkg is hung up.

                        On the permissions issue?
                        You may be trying to open files as a user, that have root permissions.
                        If that is the case, as root, you need to give your user account permissions, for that directory and file.
                        I may install a regular 18.04.02 Ubuntu so I can see what yours looks like.
                        Last edited by big_teee; 07-29-2019, 03:17 PM.

                        "If Wishes Were Horses, Beggars Would Ride!" Scottish Proverb 1600s


                        bostanci escort
                        sisli escort mecidiyekoy escort
                        pendik escort
                        sex vidio
                        altyazili porno
                        antalya escort
                        beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
                        gaziantep escort gaziantep escort
                        atasehir escort
                        antalya escort bayan escort atakoy
                        izmit escort
                        ankara escort
                        replica watches