Announcement

Collapse
No announcement yet.

'62 Kay 503A Volume Squeal

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • '62 Kay 503A Volume Squeal

    I'm getting a crazy annoying and loud squeal when I turn the volume knob up. I've gone thru the amp and have new caps. Would this problem most likely be a tube or the volume pot? If the pot, how do I test it?

  • #2
    I doubt it is the pot. COuld be a tube, or could be wire dress, or a host of other things.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      Is this one of those (tube) amps where you need to make sure the speaker is grounded to the chassis? I remember having a similar problem with an old Gibson Ranger amp. There were two leads coming off the output transformer going to the speaker. But because there was no speaker jack connected to the chassis, I had to run an extra wire from the speaker (-) to the chassis ground.

      Comment


      • #4
        I doubt its a ground issue since it is intermittent, which I should have mentioned. I'll test all the tubes tomorrow and go from there.

        Comment


        • #5
          Originally posted by Perkinsman View Post
          I doubt its a ground issue since it is intermittent, which I should have mentioned. I'll test all the tubes tomorrow and go from there.
          Could still be a tube. Sometimes they can behave and then just leap into microphony. More likely a bad solder joint, internally faulted lead or loose/dirty tube socket slot that is losing contact intermittently. But tubes are easy to test by replacement so there's no reason not to try that first.
          Last edited by Chuck H; 08-04-2019, 02:22 PM.
          "Take two placebos, works twice as well." Enzo

          "Now get off my lawn with your silicooties and boom-chucka speakers and computers masquerading as amplifiers" Justin Thomas

          "Being born on third base and thinking that you must have hit a triple is pure delusion!" Steve A

          Comment


          • #6
            Originally posted by Perkinsman View Post
            If the pot, how do I test it?
            The fastest way is to temporarily replace the pot with a pot that you know is correct.
            Check condition R7/ 3M9 and C3/ .05
            Who does not know and knows that he does not know - teach him Confucius)
            Who knows and does not know that he knows - wake him Confucius)

            Comment


            • #7
              Originally posted by TomCarlos View Post
              Is this one of those (tube) amps where you need to make sure the speaker is grounded to the chassis? I remember having a similar problem with an old Gibson Ranger amp. There were two leads coming off the output transformer going to the speaker. But because there was no speaker jack connected to the chassis, I had to run an extra wire from the speaker (-) to the chassis ground.
              As you can see in the pic, there are 2 (blue & red) leads from the OT to the tubes. There is an odd grey lead that runs from the speaker frame to the amp chassis.
              Attached Files

              Comment


              • #8
                Originally posted by Perkinsman View Post
                As you can see in the pic, there are 2 (blue & red) leads from the OT to the tubes. There is an odd grey lead that runs from the speaker frame to the amp chassis.
                Gray wire is the grounding of the speaker basket.
                It is slightly wrapped around blue & red wire to form a kind of shielded cable.
                Who does not know and knows that he does not know - teach him Confucius)
                Who knows and does not know that he knows - wake him Confucius)

                Comment


                • #9
                  Originally posted by vintagekiki View Post
                  The fastest way is to temporarily replace the pot with a pot that you know is correct.
                  Check condition R7/ 3M9 and C3/ .05
                  Can I use any size pot or does it have to be same as volume, 1/2 meg?
                  I replaced R7 & C3, still squeals when volume is over 6-7. What is 3M9?

                  I attached the schematic, btw, this is a 504 model, not a 503a as I originally posted. My bad.
                  Attached Files
                  Last edited by Perkinsman; 08-04-2019, 07:59 PM. Reason: Added jpeg

                  Comment


                  • #10
                    Originally posted by Perkinsman View Post
                    Can I use any size pot or does it have to be same as volume, 1/2 meg?
                    I replaced R7 & C3, still squeals when volume is over 6-7. What is 3M9?

                    I attached the schematic, btw, this is a 504 model, not a 503a as I originally posted. My bad.
                    Kay 503
                    https://el34world.com/charts/Schematics/files/Kay/Kay503a_1962.jpg
                    The values for R7 & C3 refer to the Kay 503A schematics; 3M9 = 3.9Meg

                    Kay 504
                    Volume pot between 1/2 Meg to 1 Meg
                    I assume there are new tubes in the Kay 504 during repair.
                    Check condition C1 (20 + 20 + 40)
                    Between R8 and R13 parallel to C1 (20) R8 and R13 parallel to C1 (20) temporarily connect 22uF/ 400V
                    Who does not know and knows that he does not know - teach him Confucius)
                    Who knows and does not know that he knows - wake him Confucius)

                    Comment


                    • #11
                      Originally posted by vintagekiki View Post
                      Kay 503
                      https://el34world.com/charts/Schematics/files/Kay/Kay503a_1962.jpg
                      The values for R7 & C3 refer to the Kay 503A schematics; 3M9 = 3.9Meg

                      Kay 504
                      Volume pot between 1/2 Meg to 1 Meg
                      I assume there are new tubes in the Kay 504 during repair.
                      Check condition C1 (20 + 20 + 40)
                      Between R8 and R13 parallel to C1 (20) R8 and R13 parallel to C1 (20) temporarily connect 22uF/ 400V
                      Interesting Update: There's 3 inputs on this amp. Inputs 2 & 3 didn't squeal, input 1 does. Bad jack?

                      Comment


                      • #12
                        Most likely to oxidize the ground from input 1.
                        Clean the chassis below input 1 and replace jack.
                        Who does not know and knows that he does not know - teach him Confucius)
                        Who knows and does not know that he knows - wake him Confucius)

                        Comment


                        • #13
                          Originally posted by vintagekiki View Post
                          Most likely to oxidize the ground from input 1.
                          Clean the chassis below input 1 and replace jack.
                          Now that you mention it, I did notice that the thin nut was looking oxidized but didn't stop to think that might cause a problem. I cleaned everything else in the amp! Tomorrow I'll clean that ring nut & the chassis underneath & report back.

                          Comment


                          • #14
                            Success!! I took the jack off, clean the chassis, used a little emory cloth on the part that makes contact with the tip of the jack and emory cloth'd the inside of the jack. Then used contact cleaner on the parts and Voila!

                            Now all 3 of the jacks work, pots are all cleaned, filter caps replaced with fresh stock and a few smaller caps. Amp sounds great at 10, tremolo is very sweet too.

                            Big thanks to Vintagekiki!

                            Comment


                            • #15
                              Glad you found a solution and repaired your amp.
                              Who does not know and knows that he does not know - teach him Confucius)
                              Who knows and does not know that he knows - wake him Confucius)

                              Comment

                              antalya escort
                              kartal escort
                              sex vidio
                              altyaz?l? porno
                              antalya escort
                              beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
                              gaziantep escort
                              Working...
                              X