Announcement

Collapse
No announcement yet.

Behringer BXL1800 static noise problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Behringer BXL1800 static noise problem

    Hi there, im in need of help please ! Ive had this Behringer BXL1800 amp for a couple of years now but has only had very light use and has been working sweet up until now, then suddenly ive started getting a constant static noise (exactly like a radio)whether or not any leads are plugged in and also the amp will hardly amplify any sound from the guitar either ! Headphones are only getting a hiss also.
    Last edited by wheelspin; 11-19-2011, 08:35 PM.

  • #2
    OK, sounds like what we call white noise - that hiss sound from a radio or TV station off the air.

    DO ANY of the controls have ANY effect on the noise? Can we turn the noise up and down or affect its tone for example.


    MY prediction is that we will find a bad op amp IC< probably a TL074.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      Hi there, many thanks for the reply ! Yes i can still turn up the volume on the white noise but next to nothing when any strings are slapped. I can also alter the tone through the equaliser. Cheers

      Comment


      • #4
        Explore IC3, a TL074. Any large DC offset on an output pin? And scope those pins or signal tracer them. One of them extra noisy?
        Education is what you're left with after you have forgotten what you have learned.

        Comment


        • #5
          Many thanks again for such a quick reply. I'll definately check those out. cheers !

          Comment

          Working...
          X