Results 1 to 11 of 11

Thread: MXR Omni Flanger/Chorus inop

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Sterling Heights, MI
    Posts
    7

    MXR Omni Flanger/Chorus inop

    Need some help here, I have a MXR Omni effects unit and the flanger/chorus effect is NW. I checked the bias voltage and clock signal, both are present. There is a input and output at the sad1024 chip, I'm not exactly sure how they sould look but the output is following the clock signal. The LED comes on, the direct signal is present but no effect. Any suggestions? Thanks in advance.

  2. #2
    Senior Member pecorporation's Avatar
    Join Date
    Jan 2010
    Posts
    257
    Not sure this will help, but I've seen a potentiometer open up on one unit a while back that had me confused for a bit. May want to verify correct values on those pots.

  3. #3
    Junior Member
    Join Date
    Jun 2009
    Location
    Sterling Heights, MI
    Posts
    7
    Good idea, checked all the pots in the circuit. All OK

    Would've been nice if one was open though...

    Checked all the solder joints too, just to make sure. No problems there either.

  4. #4
    Member
    Join Date
    Oct 2006
    Posts
    27
    I thought the Omni used SAD4096 chips?

  5. #5
    Junior Member
    Join Date
    Jun 2009
    Location
    Sterling Heights, MI
    Posts
    7
    It does have a sad4096 for the delay section, the flanger/chorus has the sad1024.

  6. #6
    Senior Member
    Join Date
    May 2006
    Posts
    3,529
    When the wet signal is omitted, any flanging or chorus effect will disappear. Consequently, it is extremely common for manufacturers to simply cancel the wet signal as their "bypass" technique. The dry signal will continue to pass in both bypass and effect mode. I don't have a schematic of an Omni (wish I did, though!), so I may be off. Possible that the switching arrangement for lifting/enabling the wet signal has gone awry? So, is there a JFET or CMOS switch that might have blown?

  7. #7
    Junior Member
    Join Date
    Jun 2009
    Location
    Sterling Heights, MI
    Posts
    7
    There is a flip/flop in both the flanger/chorus and delay circuits, not sure what for but I'll check this out later. CD4013BE

    I wish I could find the schematic also, I checked with a few local repairmen but no luck so far.

  8. #8
    Member
    Join Date
    Oct 2006
    Posts
    27
    The 4013 is used to supply a clock signal to the delay ICs.

    You can buy the schematic here: MXR*Schematics. It's $20 but if you send me a copy I'll pay half.

  9. #9
    Senior Member Nyqusit5's Avatar
    Join Date
    Mar 2009
    Location
    Lille, France
    Posts
    190
    Actually, if you send me a copy as well, I'll pay a third!

  10. #10
    Junior Member Chrisfromiowa's Avatar
    Join Date
    Oct 2017
    Location
    Somewhere in Iowa
    Posts
    19
    Quote Originally Posted by Nyqusit5 View Post
    Actually, if you send me a copy as well, I'll pay a third!
    Did you ever buy the document? I've seen one for sale that is missing the delay/flange IC chips and want to figure out if its worth buying. No such thing as a pin for pin replacement, right? Thnaks

  11. #11
    Senior Member Nyqusit5's Avatar
    Join Date
    Mar 2009
    Location
    Lille, France
    Posts
    190
    Hi,
    Unfortunately, I never got it.
    I don't know of a replacement for the SAD4096, apart from building a small add-on board with another BBD and associated adaptive circuit. I wish I did!
    Interested in old, rare, unusual or just plain bizarre music equipment?
    www.nicosonic.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS: MXR Omni
    By cjlectronics in forum Flea Market
    Replies: 0
    Last Post: 11-09-2009, 04:50 PM
  2. MXR Omni Ext. Loop not working any Ideas!
    By Tungsten12 in forum Guitar Effects
    Replies: 1
    Last Post: 10-12-2009, 06:22 PM
  3. MXR Chrous Flanger problem (OMNI)
    By elmolewis in forum Guitar Effects
    Replies: 4
    Last Post: 12-06-2008, 12:05 AM
  4. MXR Flanger 117 Issues
    By simplefun in forum Guitar Effects
    Replies: 0
    Last Post: 11-12-2008, 12:23 AM
  5. MXR Vintage Flanger MXR 117
    By guitar54 in forum Guitar Effects
    Replies: 3
    Last Post: 10-31-2008, 10:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •