Results 1 to 6 of 6
Like Tree3Likes
  • 1 Post By Jazz P Bass
  • 2 Post By ataro

Thread: Debugging a Line6 DL4. Help needed!

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    3

    Exclamation Debugging a Line6 DL4. Help needed!

    Hi!

    I hope you can help me fix a dead Line6 DL4 that won't power up and it's giving me headaches.

    First, the schematic:

    https://www.docdroid.net/JYZyjup/tmp...48780.pdf.html

    I disassembled it and made a visual inspection first. Nothing wrong. I did check voltages, all correct till U14. Touched U14 (MAX887) and was very Hot and giving wrong voltages. Pin 7 was giving 0V instead of 3.3v.



    A bunch of components are fed by the 3.3v line, with U2 (DSP56364) being one of them.



    After a lot of tracking, I found out that if I cut the 3.3v trace near pin31 of DSP56364, the voltage of the whole line is restored and MAX887 operates correctly.



    I thought that the DSP56364 was shorted, so I replaced it with a new one (super expensive, BTW) and didn't made an improvement. MAX887 is still very Hot and 3.3v drops to zero as soon as the pin31 of the DSP56364 is connected.

    Here's the DSP56364 Datasheet :

    http://www.nxp.com/files/dsp/doc/dat...t/DSP56364.pdf

    Any ideas on this? What could cause the short?

    Many thanks guys

  2. #2
    Old Timer
    Join Date
    Dec 2007
    Location
    Poland
    Posts
    1,446
    Aren't the memory ICs supplied with the same 3V3 voltage? In such a case I would check blocking capacitors like C26, C33 and others.

    The link to the schematic does not work (at least for me).

  3. #3
    Senior Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    27,553
    So U14 is hot, either it is bad or its output is loaded. You isolated U2, but was it getting hot? You showed yourself it wasn't the problem.

    Are any of the other 3v chips getting hot? And those little bypass caps, any of those get hot? Try just lifting those caps off anyway, they are more likely than the ICs to fail.
    Education is what you're left with after you have forgotten what you have learned.

  4. #4
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    11,600
    Quote Originally Posted by MarkusBass View Post

    The link to the schematic does not work (at least for me).
    Here is the downloaded file.
    Attached Files Attached Files
    vintagekiki likes this.

  5. #5
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Many thanks guys!!!

    Quote Originally Posted by Enzo View Post
    So U14 is hot, either it is bad or its output is loaded. You isolated U2, but was it getting hot? You showed yourself it wasn't the problem.

    Are any of the other 3v chips getting hot? And those little bypass caps, any of those get hot? Try just lifting those caps off anyway, they are more likely than the ICs to fail.
    Never thought of that! U2 was never getting Hot, but when I lifted it, U14 came back to life and 3v3 rail was showing voltage back, so I suspected U2 was the problem. But it can be U14 not dealing with load, that's true! No other component got hot. Bypass caps seemed fine. I have ordered one MAX887, will replace it and see what happens.
    You helped me a lot. Thanks!

  6. #6
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Solved: replaced MAX887, the pedal came back to life. Many thanks to all for the help!
    g1 and The Dude like this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Line6 DL4 power supply repair
    By beatnik in forum Guitar Effects
    Replies: 10
    Last Post: 02-05-2015, 02:20 PM
  2. Line6 dl4 doesn't power up
    By Threlyn in forum Guitar Effects
    Replies: 1
    Last Post: 06-26-2010, 07:04 PM
  3. Replies: 10
    Last Post: 06-25-2010, 07:48 AM
  4. How to remove knobs from Line6 DL4????
    By Makauto in forum Guitar Effects
    Replies: 5
    Last Post: 03-27-2010, 07:22 PM
  5. Line6 DL4 in effects loop
    By hotthands in forum Music Electronics
    Replies: 0
    Last Post: 04-09-2008, 02:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •