Results 1 to 5 of 5

Thread: Digitech GNX3 DEAD...

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Location
    Stratford NJ USA
    Posts
    17

    Digitech GNX3 DEAD...

    Hello all I bought a Digitech GNX3 "as is" to fix up for my son- I have all power supply voltages (the one 3.3 volt supply measures 3.26 volts) but no led display or other lights and or audio (I do have a slight hiss thru the headphones- but no audio) I do have the correct 2.1a 9vac supply fo it. Is there a factory reset? or has anybody run into this before? I have the schematic and could send it to you.
    -Chuck

  2. #2
    Supporting Member
    Join Date
    May 2006
    Location
    Texas
    Posts
    297
    I would recommend emailing Digitech. They have always been very good at responding to repair questions I have. I'm sure they will do the same for you. Ask them how to do the factory reset as well.

    if this doesn't work, post back here and I'd be glad to give you some help. I would like a copy of the schemo if you can send it to me. I'll look at it while you email digitech.

    cjlectronics at yahoo dot com

  3. #3
    Junior Member
    Join Date
    Feb 2008
    Location
    Stratford NJ USA
    Posts
    17

    Thanks for the tip!

    Digitech replied:
    Hi,
    Our flat rate for repairs is $85 which covers parts, labor and return
    shipping. You may want to first try downloading software version 1.5
    from Resources>Software at www.digitech.com and run the RP Updater.
    Start the updater with the power off to the GNX3 and when the Updater
    shows "trying to connect" immediately turn on the power to the GNX3.

    William Clayton
    Harman Music Group
    Technical Customer Service


    I'll try it and see...I may have to humble myself and send it to them for $85, I have to watch out sometimes it gets to be a personal challenge and I wont give up until too much time/money has been spent- LOL

  4. #4
    Junior Member
    Join Date
    Feb 2008
    Location
    Stratford NJ USA
    Posts
    17

    It's Alive!!!

    First of all I'd like to send out a big thanks to cjlectronicsfor recommending that I e-mail digitech tech support ( I figured yeah right, they are going to help out me? Mr. joe Q. wannabe-fixer-upper- guy) But they replied!!!
    As per the digitech tech support e-mail, I figured I'd try the software update before sending the unit in (I figured for sure it was a hardware problem) I purchased a USB to MIDI cable and downloaded the software for the RP updater from Digitech. I followed the instructions included in the readme file and after a while I could see the program "talking" to the GNX3, when the software was finished The lights came on. For a brief moment I shared the same feeling as Dr Frankenstien IT'S ALIVE!!!! (I SHOUTED) now I have to go and reassemble the unit and test it out....

  5. #5
    Junior Member
    Join Date
    Apr 2009
    Posts
    1
    my gnx3 is dead.. i dont speak english. i am from venezuela.. i need you healp.. my gnx3 does not update.. dont turn on.. :S please healp me...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DigiTech GSP5 schemo,please!
    By Le Basseur in forum Guitar Effects
    Replies: 15
    Last Post: 08-21-2008, 02:15 PM
  2. GSP5 Digitech
    By Axiom in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 03-19-2008, 09:54 AM
  3. Digitech GSP-2101 Limited Edition
    By Rip_Van_Stinkle in forum Guitar Effects
    Replies: 0
    Last Post: 02-25-2008, 03:07 AM
  4. Fender M-80..Digitech RP-20?
    By evildikk in forum Guitar Amps
    Replies: 1
    Last Post: 03-14-2007, 12:03 AM
  5. Digitech Bass Synth Wah Inductors
    By primussy in forum Guitar Effects
    Replies: 0
    Last Post: 11-04-2006, 11:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •